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iChecker - USER GUIDE 
 

This manual provides information on how to use the iChecker Survey Software. Procedures and functionalities of 

the iChecker Survey Software is included with the help of graphic layouts. A simple tutorial session to guide the 

user through the process will be provided. 

 

1. Getting Started with iChecker ...................................................................................................... 3 

1.1. Understanding iChecker Interface ............................................................................................................ 3 

1.2. Menu Bar .................................................................................................................................................. 3 
1.2.1. File Menu ............................................................................................................................................................ 3 
1.2.2. Regenerate Menu ................................................................................................................................................. 3 
1.2.3. Edit menu ............................................................................................................................................................ 4 
1.2.4. View Menu .......................................................................................................................................................... 4 
1.2.5. Display Menu ...................................................................................................................................................... 4 
1.2.6. Report Menu ........................................................................................................................................................ 5 
1.2.7. Help Menu ........................................................................................................................................................... 5 

2. Read / Open ASCII files ................................................................................................................ 6 

2.1. Open JUPEM ASCII Files ........................................................................................................................ 6 

2.2. Open Recent JUPEM ASCII Files ............................................................................................................ 6 

3. Graphic Check ............................................................................................................................... 7 

4. 16 ASCII Files Checking ............................................................................................................... 9 

4.1. FAH (Farahsat) ......................................................................................................................................... 9 

4.2. FBK (Field Book) ................................................................................................................................... 10 

4.3. COR (Correction) ................................................................................................................................... 11 

4.4. SOB (Solar Observation) ........................................................................................................................ 11 

4.5. BCS (Bearing Close) .............................................................................................................................. 11 

4.6. ACS (Area Comparison) ......................................................................................................................... 11 

4.7. COO (Coordinate Information) .............................................................................................................. 12 

4.8. EDM (EDM Test) ................................................................................................................................... 12 

4.9. NCP (Deduced Field Data) ..................................................................................................................... 13 

4.10. TPS (Traverses) ...................................................................................................................................... 13 

4.11. TPO (Topography) .................................................................................................................................. 13 

4.12. BLN (Base Line) ..................................................................................................................................... 14 

4.13. PO (Old Value) ....................................................................................................................................... 14 

4.14. BDY (Bearing, Distance & Coordinates) ............................................................................................... 14 

4.15. LOT (Lot Details) ................................................................................................................................... 15 

4.16. JOB (Job Details) .................................................................................................................................... 15 

5. JUPEM Check Report ................................................................................................................. 16 

5.1. NCP/BDY Rpt ........................................................................................................................................ 16 

5.2. Fahrasat Rpt ............................................................................................................................................ 16 

5.3. Area Comparison .................................................................................................................................... 16 

5.4. EDM Test ................................................................................................................................................ 17 

5.5. Station Check Rpt ................................................................................................................................... 17 

5.6. Correction Rpt ........................................................................................................................................ 18 

5.7. Close Statement Rpt ............................................................................................................................... 18 

5.8. Trav MisClose Rpt .................................................................................................................................. 18 



landsoft ® 
 

Page ii  

5.9. Lot MisClose Rpt .................................................................................................................................... 19 

5.10. Base Line Report .................................................................................................................................... 19 

5.11. Solar Report ............................................................................................................................................ 19 

5.12. FieldBook (MapInfo) .............................................................................................................................. 20 

5.13. FieldBook (CPSTablet)........................................................................................................................... 20 

5.14. Error Rpt ................................................................................................................................................. 20 

5.15. File Existence Rpt ................................................................................................................................... 21 

5.16. Lot Mark Desc Rpt ................................................................................................................................. 21 

6. Regenerate .................................................................................................................................... 22 

6.1. Regenerate *.ebk File ............................................................................................................................. 22 

6.2. Regenerate *.edm File ............................................................................................................................ 23 

7. Attachment ................................................................................................................................... 24 

7.1. LLSM Constraint .................................................................................................................................... 24 

7.2. Precautions before export file ................................................................................................................. 24 

7.3. Nombor Fail Ukur JTB follow state ....................................................................................................... 24 

 



landsoft ® 
 

Page 3 

1. Getting Started with iChecker 

After generated all the 16 ASCII files, iChecker can be used to verify the ASCII files and check whether any 

mistake occurs.  

1.1. Understanding iChecker Interface 

When you first start iChecker, the initial screen contains the menu bar at the top and the Standard Toolbar at the 

below. 

 

 

1.2. Menu Bar 

1.2.1. File Menu  

– Contains the entire menu item regarding to read / open job.  

 

Read JUPEM ASCII Read / Open JUPEM ASCII files. 

 

Read Recent ASCII View recent JUPEM ASCII files. 

 

About é View current version of CPSChecker. 

 

Exit  To close and exit from CPSChecker program. 

 

1.2.2. Regenerate Menu 

– Contains the entire menu item regarding to re generate file.  

 

*.ebk Re-generate back EBK file. 

 

*.edm Re-generate back EDM file. 

Standard 

Toolbar 

Menu Bar 
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1.2.3. Edit menu 

 

 

 

No. Fail Ukur To edit or change a survey file number.  

Match PO/New To edit or change the Match PO or New  

 

Stn Mark Desc To edit Station Mark point of work measurement. 

 

Surveyor IC To change the Surveyor IC. 

 

Edm JUBL ID To change a EDM JUBL ID. 

 

PO Ascii Info To edit and change the PO Ascii Info abou the file. 

 

 

1.2.4. View Menu 

– Contains the entire menu item regarding to view the files or data. 

 

ASCII Checker To view ASCII Check dialog for 16 files. 

 

Sketch To view field sketch of work measurement. 

  

Read PDUK To read PDUK Data 

 

Open Tiff File To open generated CP (*.tif) 

 

Jilid Kiraan  To open generated mainsheet (*.pdf) 

 

Query To view and query existing lines with their bearing and 

distances.  

1.2.5. Display Menu 

– Contains the entire menu item regarding to graphic display on screen. You can on/off the station id here.  

  

Show All  
Show the whole sketch in its original size  

Zoom By 2 Point  
Zoom in to sketch according to 2 point extent picked 

by user. 

 

Zoom In  
Zoom in. 

Zoom Out  
Zoom out 

Set View Extent Set view extent for graphic preview 

 

Pan  
To pan and navigate around the sketch 

Pan Left Pan the screen to the left. 

 

Pan Right Pan the screen to the right. 

 

Pan Up Pan the screen up. 

 

Pan Down Pan the screen down. 

 

Find Stn  
Zoom in to a station specified by user 

Toolbar Toggle SHOW/HIDE display toolbar. 
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 On/Off Lot No. Toggle ON/OFF lot ID display on sketch 

 

Black/White Bg.  
Toggle BLACK/WHITE background for sketch. 

On/Off StnID  

 

 

Toggle ON/OFF station ID display on sketch 

1.2.6. Report Menu 

– Contains the entire menu item regarding to reporting.  

 

File Existence  To generate and view File Existence report. 

 

Fahrasat  To generate and view Fahrasat (Job Information) report. 

 

Area Comparison To generate and view Area Comparison report. 

 

EDM Test To generate and view EDM Test report. 

 

Correction  To generate and view M & C Correction report. 

 

Close Statement  To generate and view Close Statement report. 

 

Trav MisClose  To generate and view Traverse MisClosure report. 

 

Base Line  To generate and view Base Line report. 

 

Solar Report To generate and view Solar report. 

 

FieldBook (MapInfo) To generate and view Field Book report in MapInfo 

format. 

 

FieldBook 

(CPSTablet) 

To generate and view Field Book report in CPS format. 

NCP/BDY  To generate and view NCP and BDY report. 

 

Station Check  To generate and view Station Check (Mark Description) 

report. 

 

Lot  MisClose To generate and view Lot MisClosure report. 

 

Lot  Mark Desc To generate and view Lot Mark Description report. 

 

Error  To generate and view Error report if occur.  

 

1.2.7. Help Menu 

– A help page will be pop up to guide for particular error.  
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2. Read / Open ASCII files 

In this part, we will show you the steps to open ASCII files. It is recommended to check the job file before and 

also after the Digital Signature (*.xml). But before that must complete process all the 16 ASCII files with 1 CP 

(*.tif) and 1 Mainsheet (*.pdf).  

2.1. Open JUPEM ASCII Files 

1. Navigate to File > Read JUPEM ASCII.  

2. An Open Dialog will appear. Look for the ASCII files that you going to check. Highlight the *.fbk file and 

click Open. 

  

3. A File Existence report will automatically pop up.  

 

2.2. Open Recent JUPEM ASCII Files 

1. Navigate to File > Read Recent ASCII.  

2. An Open Recent ASCII  dialog will pop up. Select the job which you going to check and click on Open 

button. 

 

3. A File Existence report will automatically pop up.  
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3. Graphic Check 

1. To check on the graphic, user may temporary close for the ASCII Checker Docker. Then, refresh it  to see 

bigger graphic. 

 

2. Navigate to View > Sketch, choose for the related line type and click OK . 
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3. The sketch will show out all the related line type.  

No. Colour Description 

1.  Purple Traverse 

2.  Green Lot 

3.  Grey Offset  / Topo Details 

 

4. If want to see the boundary area, please click on  Boundary on/off button. Make sure the boundary lot 

(green colour area) is in the position.  
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4. 16 ASCII Files Checking 

After open the files, click on each of the tab bar (16 ASCII files) and check on the data. You can always refer to 

the Error List Box , if anything listed there, then only highlight the list and look at the Error Description  at the 

below.  

Note: All solution need to make changes on the job file (*.ebk) and regenerate the ASCII again. 

 

 

4.1. FAH (Farahsat) 

Fahrasat ASCII File contains all the information about the side location and also the starting and ending date of 

the survey job. 

No. Error Solution 

1.  Start Date for Lot is wrong 1. Go to Job menu > Job Info menu 

2. Go to Date page and check the start date entered. 

 

2.  End Date for Lot is wrong 1. Go to Job menu > Job Info menu 

2. Go to Date page and check the end date entered 

 

3.  End Date for Lot is earlier than Start 

Date 

1. Go to Job menu > Job Info menu 

2. Go to Date page and check the range of the starting 

and ending date entered 

 

4.  Lot no is not unique 1. Go to Job menu > Job Info menu 

2. Go to Page 2 and check the Lot No. for duplicate no. 

date entered 

 

5.  Surveyor I/C no. is not complete 1. Go to Job menu > Job Info menu 

2. Go to Page 2 and entered the full I/C no. of the 

surveyor date entered 
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4.2. FBK (Field Book) 

Field Book ASCII file contain all the measure line bearing and distance. It‟s the most essential ASCII file among 

the rest. So if there is any error occurs in this ASCII field, we mostly advise you to contact us to correct it for you 

than you make changes yourselves. 

No. Error Solution 

1.  CLTo and CRTo for Line 1 - 2 is wrong. 

Diff btw CLTo and CRTo is 0.0000 

1. Check you field book. (Record > View Field Book) 

2. Check if the front Bearing is out of tolerance. 

 

2.  Mean of CLTo and CRTo for Line 1 - 2 

not same with AvgBrg.Diff more than 

0.0000 

1. Check you field book. 

2. If wrong, go search the record out, reduce again and 

save to overwrite the old value. 

 

3.  ObsDate for Line 1 - 2 is not in the date 

range of *.fah 

1. Go to Job menu > Job Info menu 

2. Go to Date page and check the starting and ending 

survey date. 

 

4.  ObsDate for Line 1 - 2 is earlier than 

previous rec 

1. If you wish to change the date. Adjust the system date 

then search the record out and overwrite the old record 

 

5.  ObsTime for Line %s - %s is earlier than 

previous rec 

1. If you wish to change the time. Adjust the system time 

then search the record out and overwrite the old record. 

 

6.  Back Brg for Line %s - %s not found 1. Check your fieldbook. If the record back brg to a 

wrong station, just edit the station ID using the “Edit 

Stn” button. 

 

7.  CLFrom for Line %s - %s is wrong 

 

1. Check your fieldbook. If the record back brg is 

incorrect, remeasure the record using the correct back 

brg. 

 

8.  CLFrom and CRFrom for Line %s - %s 

is wrong 

1. Check your fieldbook. If Face left and Face Right back 

brg is different, remeasure the record and overwrite the 

old record. 

 

 

If there is other error besides the basic error which is shown on the top list, we suggest you that to contact us to 

help to fixed the problem.  
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4.3. COR (Correction) 

Correction ASCII file contain all the C Correction and M Correction of the survey. So if you have some 

correction that apply wrongly, contact our support team to do it for you. If it you want to try it out yourselves, 

you may always can clear off all the correction and reapply it again. 

No. Error Solution 

1.  Line 1 - 2 not found in *.fbk 1. Search if the record is in the field book. If yes try to 

regenerate the *.fbk ASCII file. 

2. Or you maybe need to go back to CPSTablet and Clear 

All Corr  then re-apply correction again. 

 

2.  Corr No. for line 1 - 2 is invalid. 

No such Corr No in *.bcs 

1. Check the corr no. is in the *.bcs ascii. If not,try to 

clear all the corr and reapply it. Then regenerate *.bcs 

file 

2. Or you maybe need to go back to CPSTablet and Clear 

All Corr  then re-apply correction again. 

 

 

4.4. SOB (Solar Observation) 

Solar Observation ASCII files contain the solar values that you have taken for a particular job. 

No. Error Solution 

1.  True Bearing for Line 1 - 2 is out 

of tolerance 

1. Check your solar observation value is out of tolerance 

 

4.5. BCS (Bearing Close) 

Bearing Close ASCII files contain all your close statement values. It will show you the corr no. and value of the 

C Correction of all you corrections under *.cor file. Make sure this two files share the same value of corr and corr 

no. 

No. Error Solution 

1.  Brg Close for Line 2 - 1 not found 

in *.fbk 

1. Check the field book contains the brg close. If not try to 

regenerate the brg close record. 

 

2.  No. of stn in *.bcs for Line 1 - 2 

not same with No. of stn in *.cor 

1. Check the route of the close statement 

 

4.6. ACS (Area Comparison) 

Area Comparison ASCII file contains the area difference between your survey lot and your precomp lot. 

No. Error Solution 

1.  Negeri code for lot  not same with 

*.fah Negeri code 

 

1. Go to Job menu > Job Info menu 

2. Go to Page 1 and check the location entered 

2.  Daerah code for lot  not same with 

*.fah Daerah code 

 

1. Go to Job menu > Job Info  menu 

2. Go to Page 1 and check the location entered 
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3.  Mukim code for lot  not same with 

*.fah Mukim code 

 

1. Go to Job menu > Job Info menu 

2. Go to Page 1 and check the location entered 

4.  Seksyen code for lot %s not same 

with *.fah Seksyen code 

 

1. Go to Job menu > Job Info menu 

2. Go to Page 1 and check the location entered 

5.  Lot not found in *.fah 

 

1. Go to Job menu > Job Info menu 

2. Go to page 2 and check the lot no. entered 

 

6.  Misclosure for lot  is less than 

1:8000 

 

3. Check your computation of the lot. And check you 

brg/distance record that forms the lot 

 

7.  Percentage for lot  is more than 

5% 

 

4. Area difference is out of tolerance. May need to 

resurvey the lot 

 

 

4.7. COO (Coordinate Information ) 

Coordinate ASCII file contains all the X and Y coordinate for each station ID that you surveyed. 

No. Error Solution 

1.  Coor for station %s is invalid 1. Go to Define menu -> Coordinate menu 

2. Check the station coordinate. If both is 0.0 , go 

compute coordinate by Compute > Survey 

Computation 

 

2.  Station is a dead station.Not found 

in *.ncp 

 

1. Go to computation menu -> Delete -> Dead stn 

2. Remove all dead stn and regenerate the *.coo ASCII 

 

4.8. EDM (EDM Test) 

EDM Test ASCII file contain the distance value of the edm test. 

No. Error Solution 

1.  Distance difference for line 1 - 2 is 

out of tolerence 

 

1. Re-measure the record. The value measure is 

difference a lot from the absolute distance. 

2.  Calculate diff for line 1 - 1 not 

same with the Distance Diff in the 

ascii 

 

1. Open the edm file an save the job file again 

2. Then regenerate the *.edm ASCII 

3.  Date Format for line 1 - 2 is wrong 

 

1. Open the edm test file and check the date in the info 

page. Then save the job file again 

2. Regenerate the edm ASCII file 

 

4.  ObsTime Format for line 1 - 2 is 

wrong 

 

1. Send the edm test file to our support team to change for 

you 
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5.  Warning! ObsTime for line 1 - 2 is 

in the range from night to mid 

night time. 

 

1. Check the edm time for the record. You may set the 

wrong system time. 

2. Send the edm test file to our support team to change for 

you 

 

6.  Can't Use this EDM,*.fbk Date of 

survey is outside the EDM validity 

date 

 

1. The edm validity date is over. You need to add in a 

new edm test value which is up to date. 

 

4.9. NCP (Deduced Field Data) 

NCP ASCII file contain the final bearing and final distance of your survey. If there is any error happen here, 

contact our support team 

 

4.10. TPS (Traverses) 

TPS ASCII file contains all the traverse route, connection line, known point coordinates and lot route. 

No. Error Solution 

1.  Line 1 - 2 for route 3 not found in 

*.ncp 

1. Check the line type. If it‟s a direct line, go define it as 

direct line and compute it. Then regenerate *.ncp. 

2. Else contact our support team 

 

2.  Stn 1 not found in previous trav 

route.Wrong computation may 

occur 

1. The trav route define may define in the wrong method. 

Check the traverse route definition 

3.  Lot %s not found in *.fah 1. Lot no. does not contain in fah ascii. Check your job 

info page 2. 

 

4.  Lot 1 is not a close loop 1. All lot must have a close loop. Check your lot 

defination. 

 

5.  Known Stn %s not found in *.coo 1. Check if the coordinate in *.coo ascii file is define as 

fixed or wrong known point is define in *.tps 

 

 

4.11. TPO (Topography) 

Topo ASCII files contain your topo details information. 

No. Error Solution 

1.  StnToNo for line %s - %s is not 

same when the StringNo,Code and 

Ordered is add together 

1. Try to check your offset station ID. 

2.  Line %s - %s not found in *.fbk 1. Check your field book. If the record is in it. Search the 

offset and overwrite the old record. 

 

 



landsoft ® 
 

Page 14 

4.12. BLN (Base Line) 

Base line ASCII file contains your base line route for your new and old comparison. 

No. Error Solution 

1.  Line 1 - 2 not found in *.fbk 1. Check you field book. Search out the record and 

overwrite the old record. 

 

2.  Line 1 - 2 not found in *.po 1. Check you PO Line. If not exist, enter in the PO Line 

and regenerate the *.po ASCII file 

 

3.  Starting PO stn for Baseline No 2 

not the same with Baseline No 1 

1. You need to match the new station ID and the PO 

station ID if it‟s in the same location. 

2. If matched, check your base line route 

 

4.  End PO stn for Baseline No 2 not 

the same with Baseline No 1 

1. You need to match the new station ID and the PO 

station ID if it‟s in the same location. 

2. If matched, check your base line route 

 

 

4.13. PO (Old Value) 

PO Line ASCII file contains all the PO bearing and distance and also your PO line information such as approved 

date, UPI and etc. 

No. Error Solution 

1.  Line 1 - 2 not found in *.fbk 1. Regenerate back *.fbk 

2. Or contact our support team 

 

2.  Bearing for Line 1 - 2 not same 

with average bearing in *.fbk 

1. Regenerate back *.fbk 

2. Or contact our support team 

 

3.  Distance for Line 1 - 2 not same 

with HD in *.fbk 

1. Regenerate back *.fbk 

2. Or contact our support team 

 

4.  App Date Format for line 1 - 2 is 

wrong 

1. Check you PO Line under Define menu -> PO Line 

2. Modify the record if wrong 

 

 

4.14. BDY (Bearing, Distance & Coordinates) 

BDY ASCII file contain all the final bearing and final distance of the survey lots. 

No. Error Solution 

1.  Line %s - %s not found in *.ncp 1. Re-compute your direct line 

 

2.  Bearing for Line %s - %s not same 

with Final Bearing in *.ncp 

1. Check your final computation. 

2. This error mean bdy bearing is adopted in CPSWin32. 

The ncp file bearing must follow the bdy. 
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3.  Distance for Line %s - %s not 

same with Final Dist in *.ncp 

1. Check your final computation 

 

4.  FromStnNo for Line 1 - 2 not 

found in *.coo 

1. Check your coordinate 

2. if station does not exist, check your lot definition 

 

5.  ToStnNo for Line 1 - 2 not found 

in *.coo 

1. Check your coordinate 

2. If station does not exist, check your lot definition 

 

 

4.15. LOT (Lot Details) 

Promote an event by describing the sessions, speakers, or sponsors. Type the date, time, and location. To add 

more sessions, speakers, or sponsors, copy and paste additional text boxes. 

No. Error Solution 

1.  UPI %s not found in *.fah 1. Check your job info page 1 if the location is selected 

correctly 

 

2.  Area for Lot not same with 

SvyArea in *.acs 

1. Check your final computation of the lot 

 

 

4.16. JOB (Job Details) 

JOB ASCII file contain the starting and ending date and also your JK page no. 

No. Error Solution 

1.  CV Approved Date for job is 

earlier than complete job date 

1. Check you JK starting and ending date. 

2. Make sure the „Tarikh dilulus‟ in Job Info > Date is 

late than „Tarikh Disiap‟ (finish survey). 
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5. JUPEM Check Report 

If there is some red colour column, it means that maybe some mistake there. You will need to check and change 

again in the *.ebk. Then only export again the ASCII files to check. 

5.1. NCP/BDY Rpt 

 

 

5.2. Fahrasat Rpt 

If the surveyor name is “Unknown”, means that you may have some problem in you Sun Observation, whether 

you do not write the surveyor name in the Sun Observation Information, or you do not have a sun observation 

data. The surveyor name is taken from *.sob file.  

 

 

5.3. Area Comparison 

Error will be occurred if the percentage more than 5%. 
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5.4. EDM Test 

 

 

5.5. Station Check Rpt 

Each of the station will be compare on the coordinate which are from final comp and also field coordinate. Final 

comp coordinate is getting from *.bdy but field coordinate is getting from *.coo. 
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5.6. Correction Rpt 

 

 

5.7. Close Statement Rpt 

 

 

5.8. Trav MisClose Rpt 

Latit, Dipat, Jarak and Tikaian Lurus calculated from bearing distance from *.ncp file according to traverse route. 
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5.9. Lot MisClose Rpt 

Latit, Dipat, Jarak and Tikaian Lurus calculated from bearing distance from *.ncp file according to lot route. 

The Tikai Lurus must be smaller than 1:8000. 

 

 

5.10. Base Line Report 

 

 

5.11. Solar Report 

 

 



landsoft ® 
 

Page 20 

5.12. FieldBook (MapInfo) 

 

 

5.13. FieldBook (CPSTablet) 

 

 

5.14. Error Rpt  
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5.15. File Existence Rpt 

Check which file is not exist and make sure the file is exported and put in same folder.  

1. For CPSTablet: click on Export > JUPEM ASCII > Export All .  

2. For CPSWin32: click View > JUPEM > Generate JUPEM Files.  

After export, to gather all the file, in CPSWin32, click on Send to JUPEM > JUPEM ascii (16files) or CP (*.tif)  

or JK(*.pdf) . After export, sign the entire exported file.  

 

 

5.16. Lot Mark Desc Rpt 
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6. Regenerate 

6.1. Regenerate *.ebk File 

If you missing the *.ebk file (to be read in PockerCPS, CPSTablet or CPSExplorer), you may regenerate it from 

CPS ASCII Checker.  

1. Navigate to Regenerate > *.ebk.  

2. Enter the Filename and click Save.  
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6.2. Regenerate *.edm File 

If you missing the EDM Test *.edm file (to be attached when export the ASCII Files in PocketCPS, CPSTablet or 

CPSExplorer), you may regenerate it from CPS ASCII Checker. 

1. Navigate to Regenerate > *.ebk.  

2. Enter the Filename and click Save. 
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7. Attachment 

7.1. LLSM Constraint  

1. No online check back 

2. No produce line 

3. Cannot + - correction 

 

7.2. Precautions before export file 

1. Delete unused station. Go to Computation > Deleteé > Remove dead station and remove all the unused 

station. 

2. Make sure there are no invalid stations like station 0. Go to Define > Coordinate and click Reset All. 

3. Make sure the all Job Info is filled in correctly. 

4. Make sure the Surveyor Name inside job info and solar observation is same. 

5. Clear all correction. Check all the traverse line is it reduced correctly . If not click Reduce button and Save 

the data. Re-apply the correction. 

6. When export the EDM  file, make sure attached the EDM file that same with job info. 

 

7.3. Nombor Fail Ukur JTB follow state  

¶ Johor – PUBLJ 

¶ Kedah – PUBLK 

¶ Kelantan – PUKNBL 

¶ Melaka – PUBLM 

¶ Negeri Sembilan – PUBLNS 

¶ Pahang – PUBLPHG 

¶ Pulau Pinang – PUBLPP 

¶ Perak – PUBLPK 

¶ Perlis – PUBLPS 

¶ Selangor – PUBLSEL 

¶ Terengganu – PUBLT 

¶ WP Kuala Lumpur – PUBLWP 

 


